Download List

Projeto Descrição

Mac OS X の Mail.app を用いたメールの送信時に,Unicode文字のチェックを行い,必要に応じて文字の置換を行うとともに,日本国内で一般にメールのやり取りに用いられている ISO 2022-JP エンコーディングで送信を行うように設定するプラグインです。注:このプラグインには,受け取った文字化けしたメールを閲覧時に修正するための機能はありません。あくまでも,送信メールのテキストエンコーディングをISO 2022-JP に設定するためのプラグインです。

macOS 10.5 - 10.15.5 に対応

(Mac OS X 10.5 - 10.8.5 に対応のバージョンは,1.4.0までとなります。)

アンインストール方法

2.6.0までのバージョンは、/Users/(ユーザ名)/Library/Mail/Bundles/ にプラグインのファイルをインストールしています。 「/Users/(ユーザ名)/Library」は,Finderのメニューの「移動」をOptionキーを押しながら開いて,「ライブラリ」を選択するとアクセスが可能です。 2.7.0以降では,/Library/Mail/Bundles/ にプラグインのファイルを作成します。

アンインストールしたい場合は,LetterFix.mailbundle をゴミ箱に移動して,Mail.appを再起動してください。

なお,macOS Mojaveでは,Mail.appの環境設定内にある,プラグインの管理でチェックボックスを外しMail.appを再起動する必要があります。

Mail.appの問題の解説

標準状態のMail.appでメールを送信する時,次の2つのパターンで受信側で文面が文字化けする場合があります。

Mail.app は,ISO 2022-JP エンコーディングで送られてきたメールに返信する時,標準の UTF-8 + Base64 ではなくISO-2022-JP エンコーディングでメールを送信しようとします。この時に,返信の文面に Unicode 文字が含まれていると,ISO-2022-JP-2 というテキストエンコーディングでメールを送信します。このエンコーディングには,ほとんどのメールソフトが対応していませんので,Unicodeに対応していたとしても,高い確率でメールの文字化けが発生します。これが1つ目の問題です。

もう1つは,Unicodeに対応しない古いメールソフトで受信される場合です。Mail.appは,ASCII文字以外が文面に入っている場合,UTF-8 + Base64 エンコーディングでメールを送信するため,一部の受信メールソフトでは正しく表示が行われない可能性があります。

本プラグインは上記の問題に対して、ISO-2022-JPに変換できないUnicode文字を置き換えることで、ISO-2022-JPでメールを送信可能にします。またダイアログでUnicode文字をそのまま送信する選択をした場合にも,強制的に UTF-8 + Base64 エンコーディングに設定して送信することで問題の発生を防止します。

制限事項

ファイルを添付したメールでは,件名等のヘッダーは UTF-8 + MIME エンコーディングで送信されます。また、High Sierra以降では,添付がない場合でも,ヘッダーがUTF-8+MIMEエンコーディングになります。

またメール本文の行毎の文字数が一定値を超えるとquoted-printable形式で 送信されることを防ぐことはできません。

謝辞

このプラグインを作成するにあたり,

を参考にさせていただきました。

System Requirements

System requirement is not defined

Liberado: 2019-09-09 17:29
letter-fix 2.9.0 (1 files Esconder)

Release Notes

  • macOS Catalina 10.15 に対応しました。
  • OSのメジャーバージョンアップにより,思わぬ不具合が存在する可能性があります。ご理解の上でご使用ください。
  • macOS Mojave および Catalina では,インストール後,Mail の一般環境設定でプラグインの有効化や無効化などの管理を行う必要があります
  • (10/30追記) macOS Catalina 10.15.1 (19B88)にも対応しています。
  • (12/11追記) macOS Catalina 10.15.2 (19C57)にも対応しています。
  • ('20/1/29追記) macOS Catalina 10.15.3 (19D76)にも対応しています。
  • (3/25追記) macOS Catalina 10.15.4 (19E266)にも対応しています。
  • (5/27追記) macOS Catalina 10.15.5 (19F96)にも対応しています。

Changelog

  • macOS Catalina 10.15 GM (19A582a) に対応
  • プラグイン自体は,alpha版と同じ物です。(インストーラーの設定のみ,Mojave以前にもインストール可能に変更しています)